Degraded performance on Dust interface

Incident Report for Dust

Resolved

Resolved.
Posted Jan 21, 2026 - 16:28 UTC

Investigating

We are currently having latency issues on the Dust application. We are investigating actively.
Posted Jan 21, 2026 - 15:36 UTC
This incident affected: Dust Application (Conversations, Chrome Extension) and Dust Developer Platform (API).