High latency on Dust

Incident Report for Dust

Resolved

This incident has been resolved.
Posted Aug 24, 2026 - 11:16 UTC

Investigating

We are currently having latency issues on Dust. We are investigating actively.
Posted Aug 24, 2026 - 09:47 UTC
This incident affected: Dust Application (Conversations) and Regions (europe-west1).