US Region: Slack Integration Temporarily Unavailable

Incident Report for Dust

Resolved

Maintenance is completed.
Posted Jun 13, 2025 - 07:14 UTC

Identified

We are currently performing planned infrastructure upgrades to improve performance and reliability in our US region. During this maintenance window, Dust's Slack integration will be temporarily unavailable.
Posted Jun 13, 2025 - 05:45 UTC
This incident affected: Dust Application (Dust Slackbot).