What's Happening: We will be scaling up our EU region database infrastructure to accommodate our growing user base and improve overall system performance. This upgrade requires a brief maintenance window.
Expected Impact: - Complete service interruption: ~2-3 minutes during database restart - Degraded Performance Period (30 minutes total): • Before restart: Service may become slower as we prepare for the upgrade • After restart: Service may experience intermittent slowness as the system stabilizes • Some requests might timeout or fail during this period
Updates: We will provide real-time status updates on this page throughout the maintenance window.
We appreciate your patience as we work to improve our infrastructure.
Posted Apr 07, 2025 - 13:57 UTC
Scheduled
What's Happening: We will be scaling up our EU region database infrastructure to accommodate our growing user base and improve overall system performance. This upgrade requires a brief maintenance window.
Expected Impact: - Complete service interruption: ~2-3 minutes during database restart - Degraded Performance Period (30 minutes total): • Before restart: Service may become slower as we prepare for the upgrade • After restart: Service may experience intermittent slowness as the system stabilizes • Some requests might timeout or fail during this period
Updates: We will provide real-time status updates on this page throughout the maintenance window.
We appreciate your patience as we work to improve our infrastructure.
Posted Apr 07, 2025 - 13:56 UTC
This scheduled maintenance affected: Dust Application (Conversations, Connection - Google Drive, Connection - Slack, Connection - GitHub, Connection - Notion, Data Sources, Dust Slackbot, Chrome Extension) and Dust Developer Platform (Dust App Platform, API).