Latency to be expected on interactions with agents

Incident Report for Dust

Resolved

The incident has been resolved, a long term fix has been implemented and successfully rolled out.
Posted Mar 18, 2026 - 17:00 UTC

Update

We are continuing to monitor for any further issues.
Posted Mar 18, 2026 - 17:00 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 18, 2026 - 16:12 UTC

Investigating

We are actively investigating the issue. In the meantime, all new interactions are suspended.
Posted Mar 18, 2026 - 16:09 UTC
This incident affected: Regions (europe-west1, us-central1).