Login issues with Dust

Incident Report for Dust

Resolved

Our provider is back online, incident resolved.
Posted Dec 05, 2025 - 09:27 UTC

Monitoring

We are currently impacted by an outage with our authentication provider. Login to Dust is unavailable at this time. We are closely monitoring and will provide updates as they become available.
Posted Dec 05, 2025 - 08:56 UTC
This incident affected: Dust Application (Conversations).