Pods and conversations inaccessible

Incident Report for Dust

Resolved

This incident has been resolved.
Posted Sep 18, 2026 - 13:34 UTC

Investigating

Since 15:22 CET Dust is suffering a major outage leading to disrupted agents executions and failures to load resources across the board (agents, conversations, pods, skills). The issue has been identified and a revert is being deployed.
Posted Sep 18, 2026 - 13:28 UTC
This incident affected: Dust Application (Conversations, Chrome Extension) and Regions (europe-west1, us-central1).