High latency in Europe region

Incident Report for Dust

Resolved

Back to normal
Posted Jul 29, 2026 - 15:51 UTC

Investigating

Interactions with the platform may be slow in Europe
Posted Jul 29, 2026 - 14:04 UTC
This incident affected: Dust Application (Conversations) and Regions (europe-west1).