Users unable to access the app

Incident Report for Dust

Resolved

The authentication outage has been fully resolved. All login services are now operational, and users can access the application normally. We continue to monitor system stability to ensure consistent performance.
Posted Oct 20, 2025 - 09:31 UTC

Update

We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 09:28 UTC

Identified

The issue is ongoing. The problem has been identified as a major authentication outage affecting many services worldwide. We are closely monitoring and coordinating with our providers to restore access as quickly as possible. Dust remains accessible through Slack.
Posted Oct 20, 2025 - 08:51 UTC

Update

The issue has been identified as originating from our authentication provider. They are actively working on a fix. Dust is still accessible through Slack.
Posted Oct 20, 2025 - 07:21 UTC

Investigating

We are currently experiencing an issue with our third-party login provider, resulting in an outage of authentication services. As a result, users are unable to log in to the application.

This issue is impacting all users, and access to the app is currently unavailable. We are actively monitoring the situation and are in contact with the login provider to resolve the problem as quickly as possible.
Posted Oct 20, 2025 - 07:11 UTC